Skip to content

rediss connection stopped working in DSN #648

Description

@jeff1985

Hi,

after some recent change the rediss (note the double S!) connection scheme stopped working. I'm getting the following error:
In RedisConnectionFactory.php line 120: The given DSN "rediss://....&persistent=1&vendor=predis" is not supported. Must start with "redis:".

Rediss is implemented in the php-enqueue/redis transport:
https://github.com/php-enqueue/redis/blob/master/RedisConnectionFactory.php

The cause is probably in this commit:
php-enqueue/enqueue@7387c7f

Can you please add rediss to the supported schemes?

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions